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Description automatically generated] GEOM 4001 – Lab 1 + 2
An Introduction to Sentinel-1 Processing in SNAP & ArcGIS Pro
We will work through most steps with a set of demo data. Your final lab product should be from a new location and image that you have selected. To ensure we can compare speckle filters and thresholding correctly, the selection of an urban area with a body of water (river, lake, etc.) is required. We will be working exclusively with Sentinel-1 GRD (intensity) data.
Steps titles will be in red. 
Specific lab deliverables are highlighted. At the end of the lab document there is a separate page with all deliverables listed. 
Introduction
Sentinel-1 data can be obtained through cloud-computing platforms such as Google Earth Engine (GEE) or through the ESA’s Copernicus browser: https://browser.dataspace.copernicus.eu/.
1. [image: A screenshot of a search box

Description automatically generated]Create a Copernicus browser account. 
[image: A screenshot of a search engine

Description automatically generated]You will first need to create an account, as unregistered users are not able to query or download data.
Within the Copernicus browser, we are able to filter by data type, date, and other parameters.  Here, we are searching for Sentinel-1 GRD data, say from June 2024. 

[image: A screenshot of a map

Description automatically generated]An area of interest (AOI) can be drawn from the right-side menu, and this is required to start an image search.                              



Here, I’ve drawn the AOI around Paris, France.





[image: A screenshot of a computer

Description automatically generated]We can also use the VISUALIZE tab to see our image using different visualizations in-browser, 











You want to choose an image, the footprints of which are outlined in green, that best captures your area of interest. Then select this image for download. This can take some time!
2. Filter, search and download a Sentinel-1 GRD image. 
[image: A close-up of a computer screen

Description automatically generated][image: A screenshot of a computer screen

Description automatically generated]
The image will download as a .zip file that we will work with in the Sentinel Application Platform: SNAP (https://earth.esa.int/eogateway/tools/snap). Keep this file zipped up!
The zip file will take on the name of the image, which follows this naming convention:
[image: A diagram of a program

Description automatically generated with medium confidence]
[image: A screenshot of a computer

Description automatically generated]What if the AOI is not within a single tile? 
We can generate a subset from the mosaic of 2 Sentinel-1 images in the same swath. To do this, we need the images that cover the AOI that are acquired on the same date, and from the same orbital direction. 
Check the product info for both images to verify for date and orbit direction and download both images. 


[image: A screenshot of a computer

Description automatically generated] 

3. Next, open SNAP, or download the application
 (if necessary: https://step.esa.int/main/download/snap-download/) 

4. Add downloaded image: File > Open Product > Select Zipped image file. 
[image: A screenshot of a computer

Description automatically generated][image: A screenshot of a computer

Description automatically generated][image: A screenshot of a computer

Description automatically generated]


When loaded, you will see the zipped file in the section called Product Explorer. We can click the folders to expand, and double-click on a band to zoom the viewing window to the downloaded image. 
[image: A diagram of a wave

Description automatically generated]

Note that the ‘V’ in the logo beside the intensity bands marks this as a ‘virtual’ band which is created on-the-fly by the SNAP toolbox and not observed/written. 
The intensity is the square of the amplitude band (amplitude * amplitude) and denotes the uncalibrated measure of energy which returned to the sensor. This consists of both the real and imaginary parts of the complex radar signal, though intensity itself is no longer complex. To fit the dynamic range of the intensity data into the 16 bits of a product, the square root of the intensity value (amplitude) is stored. 
5. Subset the raster to a smaller AOI. *if you have to mosaic 2 images, skip the subset and first perform step 6 / apply orbital files.
Zoom into the desired extent, A larger image will take longer to process through the subsequent pre-processing steps, so we’ll aim for an image that is 25% or less of the entire Sentinel-1 tile.
a. Select Raster > Subset
b. In the subset window, select OK.
This subset is created on-the-fly by SNAP, and we need to manually save it if we want to re-open it in the future.
c. Right click on the subset product, and choose Save Product.
d. Approve the box requesting permission to convert the fille. 
e. Browse to the desired save location and adjust the name of the file (if needed). The extension will be .dim. 

6. [image: A screenshot of a computer

Description automatically generated]Apply orbit files. 
Satellite orbital positions are planned and approximately known however external influences, like drag or imperfections in Earth’s gravitational field, can cause drift over time. Satellite positions are recorded by a Global Navigational Satellite System (GNSS) and this data gives us our orbit information. Orbit information is stored within Level-1 products for use in pre-processing (which must be done by the user). Precise orbit files accurate to less than 5cm and are delivered within 20 days of acquisition. Original files with accuracy less than 10cm are available 3 hours after acquisition. SNAP requires an Internet connection to try to search for an updated (more precise) orbit file for new images. 
SNAP downloads orbit files and stores these into the folder …/auxdata/Orbits/Sentinel-1/ (https://www.asf.alaska.edu/sentinel/data/). 
a. In the toolbar, go to Radar > Apply Orbit File.
b. Adjust I/O Parameters tab and Processing Parameters tab to match the    images below, adjusting the Directory where the file is saved appropriately for your working environment.
c. Run the tool and Close the window when complete.

[image: A screenshot of a computer

Description automatically generated][image: A screenshot of a computer

Description automatically generated]









We can double check that the orbital file has been applied by looking at the metadata:
i. Open the Metadata subfolder for the new product in the product explorer.
ii. Double click on the Abstracted_Metadata file to see the metadata stored at this level. 
[image: A screenshot of a computer

Description automatically generated]iii. Scroll to the bottom and check that in the Description for the “orbit_state_vector_file” it says “Orbit file used” and that there is some data in the Value column.
(Optional) : If needing to mosaic 2 images—close all but the 2 calibrated files you just made.
a. [image: A screenshot of a computer

Description automatically generated]Go to Radar > Sentinel-1 TOPS > S-1 Slice Assembly
b. On the right side of the Slice Assembly window, click the Add Opened icon to select all of your open calibrated products.
i. If the bottom of the window is displaying an error, you will need to update your toolbox. If the problem persists, it may help to restart your computer.
ii. Navigate to Help > Check for Updates and follow the instructions.
iii. [image: A screenshot of a computer

Description automatically generated]Once the updates have been downloaded, restart your Sentinel-1 Toolbox.








c. In the ProductSet-Reader window, verify that the products are in the order that they should be in the mosaic. Use the four-character Product Unique Identifier and the product numbers shown in the View Window tabs and Product Explorer to reference the images. Use the green arrows to rearrange the products.
d. In the Slice Assembly tab, select both polarisation bands.
e. In the Write tab, specify the output folder and the target product name. The products will automatically be appended with the suffix _As if you choose the default name.
f. Click Run and allow the images to be processed.
g. To reduce processing times for subsequent steps, you may now wish to follow step 5 to create a smaller subset. 
h. Use the subset of this mosaic for all future processing steps! 

7. Convert digital numbers (DNs) to Backscatter (Calibration). 

S1 Level-1 products are not radiometrically corrected or calibrated. Radar reflectivity is stored
as Digital Numbers (DNs) in the S1 products and these need to be converted to physical units of
radar backscatter. SNAP automatically determines the conversion that needs to be done
depending on the input product (using the metadata).

a. In the toolbar, go to Radar > Radiometric > Calibrate.

b. Adjust the I/O Parameters tab and Processing Parameters tab to match the images below.
Make sure [image: A screenshot of a calibration

Description automatically generated]you are selecting the newly created file with the orbit information applied for the Source Product. The output file will be in the product explorer.
[image: A screenshot of a computer

Description automatically generated]
8. Apply Speckle Filtering 
Speckle is interference of backscatter from multiple targets within a pixel. We can also refer to this as noise. To fix this we apply filters which perform an operation on a window of pixels of our choosing (e.g	. 3 by 3) to reduce the variance in the area immediately surrounding a target pixel. We have lots of choices for speckle filtering. Some speckle filters are better for SAR than others. The Mean filter does not work for SAR data because dark and bright pixels cancel each other out. The Median filter preserves edges but can remove small features when the filter window is too large. All filters will have different effects depending on the window size. 

We will compare the Boxcar filter and Lee filter. The Boxcar filter is a very simple denoising technique which makes use of a moving average function. As the size of the moving window increases the smoothing effect increases and sharp edges and features are lost. The Lee Sigma filter operates on the basis of two-sigma probability of a particular distribution, so only pixels for which the neighborhood pixels have an intensity less than the calculated threshold are averaged. This usually results in better retention of lines and edges in an image.
[image: A screenshot of a computer

Description automatically generated]
a. In the toolbar, go to Radar > Speckle Filtering > Single Product Speckle Filter.

i. Make sure you are using the newly calibrated file as the Source Product!

b. Adjust I/O Parameters tab and Processing Parameters tab to match the images below.

c. Run the tool and Close the window when complete. First, we will run the tool with the boxcar filter. We are going to use a 5x5 filter size (aka window size), meaning that the tool will look at a group of 25 pixels (5x5) to calculate the moving average.
[image: A screenshot of a computer

Description automatically generated][image: A screenshot of a computer

Description automatically generated][image: ]
Complete the same process, including appropriate re-naming of the output file and 5x5 filter size for the Boxcar and Lee Sigma filters. The Lee Sigma Filter also requires a “target window size”, which is used for point target detection. If the center pixel value is above a preset threshold and a certain percent of the other pixels in the same target window are also above the threshold, then these pixels are considered as point target pixels and their values are preserved directly without filtering. Use a 3x3 window size for a “target window size”. Number of looks (1) and Sigma (0.9) can be kept to their default values. 
[bookmark: _Hlk187228241]___________________________________________________________________________________________
Deliverable 1: Using the image you selected, complete the above preprocessing steps and compare each type of speckle filtering, and the unfiltered image. (You can view multiple images simultaneously by opening each image then going to the toolbar and using Window > Tile evenly). Provide answers to the following questions: (6 points)
· Has the speckle filtering improved the image? (1)
· Is this an indicator of a better image for processing? Why or why not? (1)
· Which speckle filtering method worked best here?  (1)
· How does the selected filtering method work? (1)
· Which features appear distorted or preserved in this ‘best’ filtered image? (1)
· Provide a screenshot of the side-by-side images of the unfiltered image and filtered image (1)


Deliverable 2: Provide the names of the image(s) downloaded and provide a breakdown of their naming convention and product info as listed below. (2 points)
What is the:
· 
· Product type? (0.25)
· Product class? (0.25)
· Polarization? (0.25)
· Date? (0.25)
· Absolute orbit number? (0.25)
· Orbital direction? (0.25)
· Processing level? (0.25)
· Beam mode (0.25)

___________________________________________________________________________________________

9. [image: A screenshot of a computer

Description automatically generated]Convert Linear to dB.
[image: A screenshot of a computer program

Description automatically generated]Calibrated SAR data are stored either as linear power, or as decibels. To manually convert between linear and decibel, you multiply the linear power by 10 * log10. The dB conversion is used mostly for visualisation, because SAR images have a large dynamic range, and dB conversion puts more emphasis on smaller values as compared to larger values.

a. In SNAP, simply right click on the band you want to convert and select “Linear to/from dB” conversion. Do this for both bands. Two new bands will be added to your image.

b. Work with these bands moving forward!


10. [image: A screenshot of a computer

Description automatically generated] Apply Geometric Correction 

S1 Level-1 images do not have geographic coordinates (you may have noticed the image appears rotated!). SAR images are acquired in slant geometry. We need to convert the image to use a coordinate system so that we can apply our work on the earth’s surface (i.e. ground). Due to variations in terrain elevation the signal can be distorted and cause phenomena like foreshortening and shadow. In SNAP we will use Range Doppler Terrain Correction which corrects the geometric distortions to the image caused by topography using a DEM (Digital Elevation Model) and the orbit file (which we already applied). This makes the pixel geolocations accurate to the real world.



[image: A screenshot of a computer

Description automatically generated]a. Use the best filtered image (either Boxcar or Lee depending on your assessment).  
b. In the toolbar, go to Radar > Geometric > Terrain Correction > Range Doppler Terrain Correction.
c. Adjust I/O Parameters tab and Processing Parameters tab to match the images shown.
d. Run the tool and Close the window when complete.

___________________________________________________________________________________________
[bookmark: _Hlk187228325]Deliverable 3:  Provide a screenshot of the filtered image and the terrain corrected image side-by-side in SNAP. In the description, explain the difference between the corrected and un-corrected products. (2 points)
___________________________________________________________________________________________

11. Export your pre-processed image as a GeoTiff and open it in ArcGIS Pro. 

a. File > Export > GeoTiff
i. Make sure you’re saving the Terrain Corrected image
ii. Make sure you’re exporting to a sensible directory
iii. Adjust the name if needed and then select Export Product
b. Open in ArcGIS Pro.

Arc will automatically display a stretch raster based on band 1. Unfortunately, GeoTiff doesn’t support that metadata, so we don’t have them nicely named. However, from the order in SNAP we know them to be VH (1) and VV (2). We can also compare general brightness of the images to confirm our thoughts on this. Your bands could be in a different order in SNAP, so it’s important to check the order from the image you exported. 
[image: A screenshot of a computer

Description automatically generated]
In the above example with a subset of France, the VH image (Map 2, left) is darker overall than the VV image (right). Why might this be?
[image: A screenshot of a computer

Description automatically generated]What we actually want to do here is create a VH/VV ratio band that can be used in analysis, or to create an RGB single-date visualisation. 
There are tools in ArcGIS Pro for creating other SAR indices, but we don’t have the bands required to use them. Further, the Binary Thresholding available in Raster Analysis does not allow us to choose our our threshold values. So, we might want to get a bit creative!
12. Make an RGB visualisation through Create Colour Composite:
a. Imagery tab > Raster Functions > search ‘colour’ (or go to Data Management ) and select Create Colour Composite
b. Set raster to your SAR image, method to ‘band name’,  red expression to “B1” (VH), green expression to band 2 (VV) and blue expression to “B1/B2” (VH/VV). 
[image: A screenshot of a computer

Description automatically generated]



___________________________________________________________________________________________
[bookmark: _Hlk187228336]Deliverable 4:  Make a simple map of the RGB SAR image in ArcGIS Pro. Use a small AOI with a feature that may be accentuated by this change in visualisation, and explain this feature and why it may be distorted/highlighted by the choice of visualisation (RGB vs grayscale) in the description. (5 points)
Points to consider: brightness/intensity values of the features in VV and VH polarisations? What features are VV and VH likely to accentuate? Is there anything that may be highlighted by the use of a ratio band or RGB visualisation? (Other than it looks super cool!). Is it helpful to view it next to the grayscale image? Use map choices that highlight your argument!
___________________________________________________________________________________________

Thresholding
[image: A satellite and a satellite

Description automatically generated with medium confidence]A common use of SAR imagery is to separate land and water using thresholding. A threshold is a value which separates a distribution into 2 distinct classes and should be defined based on the distribution of the back scatter coefficients. It is most easily decided when the distribution is bimodal, causing 2 distinct groups of pixels to emerge. Thresholds can be determined manually through examination of the distribution, or through the use of an algorithm (e.g. Otsu thresholding). 
[image: ]Thresholding of SAR intensity values works to separate land and water in large part due to the specular reflectance of water: the signal bounces off the water (provided it is a relatively smooth surface) and little or no backscatter is returned to the sensor, resulting in ‘dark’ pixel values over water. It’s notable that rough water/waves can increase scattering and could be a source of misclassification on this basis. We see brighter pixels as a product of a more intense signal returned to the sensor, which is typically achieved through a scattering mechanism on a rough(er) surface. In the case of flooded vegetation, do you think the intensity of the return would be higher (brighter) or lower (darker)? If water is dark/low intensity return, it could seem that flooded vegetation would have a lower intensity return than on-flooded/dry vegetation. However, flooded pixels with emergent vegetation often exhibit higher intensity, as the water and subsequent specular reflectance facilitate double bounces and increased volume scattering. 
For flood monitoring, a common approach is to mask out the permanent water bodies and threshold the SAR image to highlight newly flooded areas.

[image: A screenshot of a computer

Description automatically generated]Thresholding can be done with either the VV or VH polarisation. VV polarisation may be helpful in that it enhances water surface roughness, while VH is more sensitive to variations in vegetation cover and is typically preferable for mapping waterbodies or flooded areas (Kavats et al., 2022). We’ll try with both VV and VH, but first we need to separate the bands. 
13. Extract individual bands from the image using Extract Bands.
a. [image: A screenshot of a computer

Description automatically generated]Go to the Imagery tab > Raster functions > search ‘extract’ > select Extract bands.
b. Input the raster, select Band Names as method, and select Band 1 (or Band 2, you will do this for both bands).
c. Run the tool and repeat for the other band. Remember which one refers to VV and VH and consider renaming the output rasters to match their polarizations!
[image: A screenshot of a computer

Description automatically generated]

[image: A screenshot of a computer

Description automatically generated]The result is a single band raster for each band. We can see the min and max values in the stretch, but maybe we want to examine the distribution.

d. Right click layer > Create Chart > Histogram > Set band to number variable.   
e. Examine the distribution.	
[image: A screen shot of a computer

Description automatically generated]In my image and distribution, we can see that the mean pixel value is -7.72, and a sort-of bimodal distribution with peaks around -10 and 0. If I click on one of the pixels of known water to see the value, its around -18/-19. However, darker land areas can also be around this value. It’s unlikely we’ll get a perfect mask here, but we’ll experiment by setting threshold at -20 and -18.

14. [image: A screenshot of a computer

Description automatically generated]Manually set thresholds using the Reclassify tool.
a. Analysis > Geoprocessing tools > Reclassify. Input raster = your extracted VH band, Reclass field = VALUE. 
b. Click ‘Classify’, set the number of classes to 2, then change the method to ‘Manual’. Hit ‘OK’.
c. Change the end range of the first class (the start range here is the lowest pixel value of the raster) to -20. For the second class, change the start range to -20, and keep the end range here (the highest values that exist in the dataset) the same. Ensure these changes save in the table! Rename the output raster appropriately and hit ‘Run’. 
d. Repeat this for a threshold of -18.


___________________________________________________________________________________________
[bookmark: _Hlk187228353][image: A screenshot of a map frame

Description automatically generated]Deliverable 5.  Make a simple map to directly compare the resulting reclassified rasters for each threshold. In the description, provide an interpretation of each raster with reference to the range of the raster, the distribution, the threshold selected, and issues/limitations that are observed. Why does this work or not work? Are there other conditions under which this is more suitable? How does polarisation affect this? (Consider the next part of the lab for this!)  (5 points)
Tip: We can link the extent of 2 maps in the layout to ensure that the same extent for each. First, make the layout with 2 maps side-by-side. Next, right click the second map > Properties > 2nd tab > Display options > Constraint > Linked map frame extent. Now, any time you activate the first map and change the extent, the second map will immediately update to match.
___________________________________________________________________________________________

[image: ]The above steps will probably not result in the cleanest of threshold maps to separate land and water. Typically, we want an area that exhibits a clearer bimodal distribution, which we’ll see more in coastal or flooded imagery with more water. To show this better, we’ll use an image over the Bay of Fundy, Canada to see is we can produce improved thresholds manually, or through the Otsu thresholding function.
It’s good to note that during the  pre-processing process in SNAP, the Range Doppler Terrain Correction will select to ‘mask out arears without elevation’ by defaults. This can be an issue when we actually do want the areas of low-lying elevation. If you run through these steps and the image loaded into ArcGIS Pro looks like the water has already been masked out, this is likely why!
[image: A screenshot of a computer

Description automatically generated]You’ve been provided a pre-processed image of the Bay of Fundy. 
[image: A black and white image of a river

Description automatically generated]
Immediately we can see that there is a big difference between water and land. There is also a distinct darker shade of grey: these are low elevation areas that were (at least historically) salt marshes! They are still wetter than the surrounding land, whether they continue to be marsh or have been converted for agricultural purposes. 
We’re going to try manual thresholding and the binary Otsu thresholding tool on this new image. 

15. First we need to extract the VV and VH band. Go back to step 13 to review this process! 
Hint: the band order is in an above screenshot, and re-naming the bands may help you keep track of things! 

Next, we’ll use the Binary Threshlding tool. You can read the documentation for this tool here:
https://pro.arcgis.com/en/pro-app/latest/help/analysis/raster-functions/binary-thresholding-function.htm 

16. [image: A screenshot of a computer function

Description automatically generated]Next, use Binary Thresholding (Otsu) on the preprocessed and raw SAR imagery from the Bay of Fundy. 
a. Imagery > Raster Functions > Analysis > Binary Thresholding.
b. Input the raster desired > create new layer. 

[image: A graph of a number of bands

Description automatically generated]It’s not a great result, is it! So let’s try a manual threshold again after consulting the histogram for the VH band:


The histogram here actually appears to have 3 peaks, and I’d guess the 3rd is the marsh areas that appear dark grey. We can see the desired biomodal distribution on the left. We could want to choose a value that falls between these 2 peaks to set the water threshold. 


___________________________________________________________________________________________
[bookmark: _Hlk187228395]Deliverable 6. Compare the Otsu thresholding to manual thresholding (as done for deliverable 7) comment on the possible sources or error, limitations, and ideal applications.  (2 points)
___________________________________________________________________________________________

Deliverable 7. Choose and implement a manual threshold for the image. Display your result on a map layout with a description that includes an explanation of why this threshold was selected, and an interpretation of the distribution with reference to the geographic context. (6 points)
___________________________________________________________________________________________
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SEE NEXT PAGE FOR FULL LIST OF DELIVERABLES


ALL DELIVERABLES: (25 Points)
__________________________________________________________________________________________
Deliverable 1: Using the image you selected, complete the above preprocessing steps and compare each type of speckle filtering, and the unfiltered image. (You can view multiple images simultaneously by opening each image then going to the toolbar and using Window > Tile evenly). Provide answers to the following questions: (5 points)
· Has the speckle filtering improved the image? How/why? (1)
· Which speckle filtering method worked best here?  (1)
· How does the selected filtering method work? (1)
· Which features appear distorted or preserved in this ‘best’ filtered image? (1)
· Provide a screenshot of the side-by-side images of the unfiltered image and filtered image (1)
___________________________________________________________________________________________
Deliverable 2: Provide the names of the image(s) downloaded and provide a breakdown of their naming convention and product info as listed below. (2 points)
What is the:
· 
· Product type? (0.25)
· Product class? (0.25)
· Polarization? (0.25)
· Date? (0.25)
· Absolute orbit number? (0.25)
· Orbital direction? (0.25)
· Processing level? (0.25)
· Beam mode (0.25)

___________________________________________________________________________________________
Deliverable 3:  Provide a screenshot of the filtered image and the terrain corrected image side-by-side in SNAP. In the description, explain the difference between the corrected and un-corrected products. (2 points)
___________________________________________________________________________________________
Deliverable 4:  Make a simple map of the RGB SAR image in ArcGIS Pro. Use a small AOI with a feature that may be accentuated by this change in visualisation, and explain this feature and why it may be distorted/highlighted by the choice of visualisation (RGB vs grayscale) in the description. (4 points)
Points to consider: brightness/intensity values of the features in VV and VH polarisations? What features are VV and VH likely to accentuate? Is there anything that may be highlighted by the use of a ratio band or RGB visualisation? (Other than it looks super cool!). Is it helpful to view it next to the grayscale image? Use map choices that highlight your argument!
___________________________________________________________________________________________
Deliverable 5.  Make a simple map to directly compare the resulting reclassified rasters for each threshold. In the description, provide an interpretation of each raster with reference to the range of the raster, the distribution, the threshold selected, and issues/limitations that are observed. Why does this work or not work? Are there other conditions under which this is more suitable? How does polarisation affect this? (Consider the next part of the lab for this!)  (5 points)
Tip: We can link the extent of 2 maps in the layout to ensure that the same extent for each. First, make the layout with 2 maps side-by-side. Next, right click the second map > Properties > 2nd tab > Display options > Constraint > Linked map frame extent. Now, any time you activate the first map and change the extent, the second map will immediately update to match.
___________________________________________________________________________________________
Deliverable 6. Compare the Otsu thresholding to manual thresholding (as done for deliverable 7) comment on the possible sources or error, limitations, and ideal applications.  (2 points)
___________________________________________________________________________________________

Deliverable 7. Choose and implement a manual threshold for the image. Display your result on a map layout with a description that includes an explanation of why this threshold was selected, and an interpretation of the distribution with reference to the geographic context. (5 points)
___________________________________________________________________________________________
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